Test Your System

Failed. We have detected that your operating system does not meet the optimal webcast specifications for listening to and/or viewing webcasts. (...)
We recommend the following operating systems: Windows 7 or Windows XP SP2, and Mac OS X 10.4. (...) Please note that users with older versions of Windows (Windows NT 4.0, Windows 98, Windows ME, Windows 95), Mac, Linux, and Unix operating systems may or may not experience difficulties listening to and/or viewing webcasts. (...) Please contact your network administrator regarding any operating system upgrades.
 
Damn it, Jane. I though we were living in the XXIst century. Aren't we yet?

Here
Newer Post Older Post Home